Commandes, codes, fonctions, etc ...
à utiliser dans vos applications

Page mise à jour le : 28/03/2001

Adapter la largeur d'une colonne en fonction de son contenu.
         Colums("A").AutoFit
Afficher un message ordinaire.
         MsgBox("Vous êtes le bienvenu")
Afficher un message dans la barre de status.
         Application.StatusBar="Programme en cours d'exécution ..."
Copier les données issues d'un filtre automatique vers une autre feuille.
         Sheets("Feuil1").AutoFilter.Range.Copy Sheets("Feuil2").Range("A1")
         ou
         Sheets("Feuil1").Range("_FilterDatabase").Copy Sheets("Feuil2").Range("A1")
Définir l'imprimante par défaut.
         ActivePrinter="Canon LBP-465 sur LPT1"
Définir la ligne de titre.
         ActiveSheet.PageSetUp.PrintTitleRows="$1$1"
Délimiter du texte dans une cellule.
         ActiveCell.WrapText=True
Documenter une fonction personnalisée.
         Application.MacroOptions "InsereCheminClasseur", "Récupère le chemin du classeur."
         InsereCheminClasseur : Nom de la fonction
         Récupère le chemin du classeur : Définition de la fonction

Figer le défilement de l'écran.
         Application.ScreenUpdating=False
Insérer un commentaire dans une cellule (non VBA).
         =SOMME(A10:A11)+N("Ceci est un commentaire")
Insérer la formule SOMME à une position variable.
         Range("A1").End(xlDown).Offset(1, 0).Value = "=SUM(A1:" & Range_
         ("A1").End(xlDown).Address & ")"

Redéfinir la plage pour utiliser la combinaison de touches Ctrl+Fin.
         Lorsque l'on supprime des lignes ou colonnes, Excel garde toujours la même
         référence de la dernière cellule utilisée bien qu'elle soit vide.
         Pour remédier à cela, une ligne de code :

         ActiveSheet.UsedRange
Sélectionner la plage utilisée dans une feuille de calcul.
         ActiveSheet.UsedRange.Select
Sélectionner la plage en cours sans prendre en compte la ligne de titres.
         With Selection.CurrentRegion
                  Intersect(.Cells, .Offset(1)).Select
         End With

Sélectionner la zone en cours.
         Nota : La zone en cours est une plage limitée par toute combinaison de
         lignes et de colonnes vides.

         Range("A1").CurrentRegion.Select

Somme d'une plage variable (Non VBA).
         Nota : La plage se situe dans la colonne A (A1 à Ax) et celle-ci possède un titre.
         =SOMME(DECALER(A2;NB(A:A)-1;;-NB(A:A)-1))

Trouver la première ligne vide.
         Cette commande permet de trouver dans une plage, la première ligne vide.
           NoLgn = ActiveSheet.UsedRange.Row + ActiveSheet.UsedRange.Rows.Count
         Cette commande permet de trouver dans une colonne (A), la première ligne vide.
           premLiVide = Columns(1).Find("", [A65536], , , xlByRows, xlNext).Row


Free counter and web stats