Les formules Excel

Page mise à jour le : 30/12/2012

Vous trouverez dans cette rubrique un recueil de formules pouvant vous rendre de précieux services.

Calcul sur 12 mois glissants.
Calcul sur les heures.
Calcul de l'ancienneté en Mois et Années.
Calculer une somme entre deux bornes.
Exemples de formats personnalisés.
Moyenne ne tenant pas compte des valeurs zéro.
Réaliser un filtre élaboré (Champ calculé).
Réaliser un filtre élaboré (Champ avec condition ET).
Récupérer la valeur d'une cellule résultant d'une intersection Ligne/Colonne.
Somme des cellules (A1 par ex.) de plusieurs feuilles.
Somme d'une colonne avec un nombre de lignes variable.
Trouver le quantième du jour.
Trouver les dates mobiles (jours fériés).


Calcul sur 12 mois glissantsRetour au début

Calcul sur 12 mois glissants

Calcul sur les heuresRetour au début

Calcul de l'ancienneté en Mois et AnnéesRetour au début

Calculer une somme entre deux bornesRetour au début

Exemples de formats personnalisésRetour au début

Moyenne ne tenant pas compte des valeurs zéroRetour au début

Réaliser un filtre élaboré (Champ calculé)Retour au début

Le champ calculé permet d'extraire les noms dont le salaire actuel
est >= au salaire de début x 2 .

Réaliser un filtre élaboré (Champ calculé avec condition ET)Retour au début

Extraire les noms dont la date de début est >= au 31/12/1997 ET la date de fin < 01/01/2001.

Récupérer la valeur d'une cellule résultant d'une intersectionRetour au début
Ligne/Colonne

Somme des cellules (A1 par ex.) de plusieurs feuillesRetour au début

Somme d'une colonne avec un nombre de lignes variableRetour au début

   Cas 1 : Les valeurs commencent à la ligne 1
      =SOMME(DECALER($A$1;NB(A:A);;-NB(A:A)))

   Cas 2 : Les valeurs commencent à la ligne 2
      =SOMME(DECALER($A$1;NB(A:A);;-NB(A:A)-1))

Trouver le quantième du jourRetour au début

Trouver les dates mobiles (jours fériés)Retour au début

Les jours fériés sont de deux sortes :
      Jours à date fixe (comme le 14 juillet, le 11 novembre et le 25 décembre)
      Jours mobiles, dont la date varie d'une année sur l'autre. Ces jours fériés mobiles sont calculés d'après la date du dimanche de Pâques.
Dès lors que l'on connaît la date du dimanche de Pâques, on peut en dériver les dates de tous les jours fériés mobiles par simple addition.
Le dimanche de Pâques est le premier dimanche qui suit la première pleine lune après l'équinoxe de printemps (21 mars).
La formule suivante, signée Norbert Hetterich, renvoie la date du dimanche de Pâques pour l'année A
(entre 1900 et 2078) :
        =FRANC((JOUR(MINUTE(A/38)/2+55)&"/4/"&A)/7;)*7-6
Les jours fériés mobiles en France et en Belgique sont le Lundi de Pâques (Dimanche de Pâques ("DP") + 1),
le Jeudi de l'Ascension (DP + 39) et le Lundi de Pentecôte (DP + 50).
En partant de la formule de N. Hetterich, on peut donc obtenir facilement les dates de ces trois jours
fériés pour une année donnée (entre 1900 et 2078) :

Free counter and web stats